Willkommen in der neuen a68k-Galerie        
und bei der weltweit bekannten und geschätzten "Amiga-Heidelberg-Connection"     

Zurück zur Startseite





 [ 1 Beitrag ] 
 Beitrag Verfasst: Sa 1. Jan 2000, 01:00 
WinUAE habe ich ja schon länger im Einsatz, hat den Vorteil, man muss nicht wegen jedem Piep einen echten Amiga anwerfen und kann die Mädels etwas schonen :)
Ist schnell mal auf einem Netbook gestartet und läuft ja da auch richtig angenehm. Schon länger überlegte ich, ob ich mir nicht mal eine UAE Kiste schmieden sollte ?!

Origineller habe ich das E-UAE zwar auch auf dem 001.gif

Aber sooo schnell läuft es halt da auch nicht, da keiner die Motivation besitzt hier wenigstens mal den JIT überhaupt ins Leben zu rufen... So sterben leider immer wieder aufgrund Faulheit und Tellerrandgrenze gute und innovative Dinge ...

Diesen Sommer bekam ich dieses nette Kistchen für lau in die Finger:
(links im Bild)

UAE_001.jpg


Verbaut war ein mini ATX Board mit einer VIA CPU @ 1000 Mhz - nicht wirklich viel. Sollt ich den als kleines Serverlein laufen lassen? oder ...
Mal UAE probiert. Lief in der RTG Emu ganz flott.

UAE_002.jpg


Aber erst einmal musste ich mir noch ein externes Netzteil besorgen (12V und 5A) und die interne Spannungsregelung überholen.
Typische Elko-Abdankung. Billiger China-Krempel!

UAE_003.jpg


So schauts dann aus. Die Elkos gleich gelegt, um in der Höhe weniger Einschränkungen zu haben.
Mittig sieht man auch die SSD, eine 2GB Transcent. Heute noch um die 50 Euro zu haben, aber A.-lahm! Ist jeder USB2.0 Stick schneller. Spielzeug.
Der kommt demnächst in meine A1200CD, da fällt das nicht auf
:D
UAE_004.jpg
UAE_005.jpg


Hier ist die CD-Rom Blende noch original, was wir gleich mal ändern wollen!

Ein DVD Laufwerk war schnell gefunden und musste mangels originaler Halterung mit zwei Adapterungen versehen werden:

UAE_006.jpg
UAE_007.jpg
UAE_008.jpg


Und für eine vernünftige Optik musste auch das Acrylglas wieder dran. Eine Schraube musste gekürzt werden, eine ist fix und die andere Schraube hat etwas Spiel, damit der Auswurfknopf noch seine Funktion erfüllen kann.
UAE_009.jpg
UAE_010.jpg


Laufwerk noch mal selbst mit der Blende und rechts eingebaut. Hier auch noch der Versuch mit einem CF Adapter.
Aber der IDE Kontroller war unfähig, die CF Karte ordentlich als "Festplatte" anzusprechen... VIA eben.

UAE_012.jpg
UAE_013.jpg


Der Versuch mit einem 16GB USB Stick glückte soweit, aber war mir zu langsam. Also Nägel mit Köpfen und die ganze emulierte Schiete raus, und eine echte Platte rein! Auch gut zu sehen, der CD-Rom -> Sata Adapter. Das Board hat neben dem IDE auch noch Sata.
UAE_014.jpg


Soweit so gut ja. Nur, wenn schon einen Amiga emulieren, sollte auch eine echte Amiga Tastatur ihren Dienst tun. Ich habe lange gesucht ... viele Ideen/Überlegungen ... doch es half alles nichts. Ein Tipp von einem Forum-Mitglied brachte die ultimative Lösung! Denn ich wollte per KVM zwischen meinem A4000T und der UAE umschalten und nicht noch mehr Eingabegeräte auf dem Tisch stehen haben:

UAE_015.jpg


Einfach nur genialst! In die DIN Buchse kommt eine Amiga-Tastatur und die USB verbindet man mit dem PC, Mac oder was auch immer.
Wird als 'normale' Tastatur erkannt und eingebunden.

Apropos KVM ... ich hatte wenig Lust mir einen neuen KVM kaufen zu müssen und da die alle stur, ignorant und dumm (wie ihre Macher) programmiert werden, kann keiner davon noch eine Amiga-Tastatur durchschleifen. Warum auch ein elektronischer KVM nicht einfach das, was er vorgesetzt bekommt weiter reichen kann entzieht sich bislang jedem der sich damit schon beschäftigte. Hauptsache Hype-gemäß und entsprechend überteuert.
Genug Schimpferei :) Ich nutze weiterhin meinen mechanischen 4fach KVM und musste ja nun etwas anpassen...
Da die Amiga-Maus USB und PS2 kann, war auch hier die Lösung einfach.
Also einen alten defekten USB Hub zerlegt, die Buchsen auf SUB-D Stecker gelötet und auf den KVM gesteckt:

UAE_021.jpg
UAE_022.jpg
UAE_023.jpg
UAE_024.jpg


A4k: Cocolino -> Adapter PS2-USB -> USB Kabel zum KVM
UAE: provisorisches USB Kabel USB zum KVM.

Nun schaltet der KVM zwischen den beiden Rechnern hin und her, die Maus passt sich selbst auf USB oder PS2 an.

Die Tastatur ist direkt an den KVM angesteckt, von dort läuft sie direkt zum A4000T - oder - über den Konverter auf USB an die UAE-Kiste.

UAE_025.jpg


Die Umkonfiguration der Tastatur und einige Stolpersteine lagen mir aber dennoch noch im Weg.
Dank dem Macher des Konverters und dem UAE Macher und vielen Stunden Probierereien, hatte ich dann doch noch mein Ziel erreicht.
Der Konverter setzt die [ und ] Tasten als F11 und F12 um. Aber F12 wird von WinUAE schon strikt als Konfigurations-Menü-Taste verwendet ... fragt mich jetzt bitte nicht wie, aber irgendwann (!) hatte ich das ganze Gelumbe mal soweit, dass es nun wie man es sich wünscht funktioniert. Die umgelegte F11 ist nun die richtige [ Taste und gleiches gilt für die F12 und ] Taste.
Ein weiterer Pferdefuß steht allerdings noch auf dem meinigen:
Der Amiga hat, wie einst die ersten Tastaturen, die Taste für Backslash und Raute noch getrennt. Beim PC hatte man diese irgendwann zusammen gelegt (US, DOS,...) Der Konverter verhält sich hier 'neutral' wie er es sollte, nur die PCs kennen hier kein Pardon mehr.
Vielleicht ist es irgendwann mal möglich hier einen anderen Tasten-Code zu verwenden, oder ich finde heraus wie ich die auftrennen kann. Allein mit Tastatur-Maps unter Windoof hat es nicht funktioniert. So lange muss die Amiga HELP Taste für den Backslash her halten. Kann man ja eigentlich auch mit leben - hat die HELP Taste schon einmal jemand für irgend etwas halbwegs sinnvolles benutzt? :P


Nun könnte man denken, das war es ... Nein! :D
Es stellte sich nun leider heraus, dass das VIA Board mit seiner 1000 Mhz CPU und dem 100Mhz FSB eine zu lahme Krücke ist.
Hier hat man ein gutes Potential verschenkt (ich könnte es endlos fort führen, über die Kompetenzen bei VIA & Co. ... lassen wir das!)
Nun war ich so weit gekommen und habe es nicht eingesehen, einen Rückzieher zu machen! Also ein neues Board musste her.
Vor längerer Zeit schon, hatte ich bei Reichelt ein Atom Board in Beobachtung.
2-Core Atom 1800 Mhz ... rennt ordentlich!
Preislich war es nicht uninteressant, schwankte der jedoch je nach Verfügbarkeit zwischen 70 und fast 100 Euro. Ich hatte halbwegs Glück und es für knapp 80 Euro bekommen. Noch ein Speicherriegel musste auch her, 2GB sollten ja mal locker reichen.
Das Board hatte nun leider keine IDE mehr, nur zwei SATA... Da gerade eine Platte von einem Netbook, in dem ich nun eine SSD im Einsatz habe, frei geworden war, sollte die nun ihren Dienst darin aufnehmen. Schaffte es sogar das XP ohne BlueScreen darin zu starten und die Treiber alle zu installieren, aber ich zog mir einen Erbe unfähiger Programmierer der Netbook-Software (Gigabyte T1028) mit ins neue System. Immer wieder "klemmten" Tasten ... wie auf dem Netbook. (keiner weiß was die da für einen riesen Murks gebaut haben) Also das XP in den Jordan geschickt und neu aufgesetzt. Nun lief die Kiste auch problemlos. UAE eingerichtet und ...

Nächstes Ziel war es, auf dieser großen Sata Platte noch die Amiga-Partitionen mit unterzubringen.
Im WinUAE hat man es mit irgend einer Version untersagt, dass Amiga Partitionen auf der gleichen Platte sein dürfen. Ob die das je mal in den Griff bekommen können? Wäre ja echt nett!
Somit musste das Amiga OS auf ner USB Platte bleiben.

Die USB Platte wanderte nun auch in die Kiste rein:

UAE_031.jpg
UAE_032.jpg
UAE_033.jpg


einfach mal einen IDE-USB Adapter direkt verdrahtet :D

Womit die WinUAE Kiste eigentlich als "fertig" anzusehen ist ...

Wären da nicht noch so Kleinigkeiten, dass bspw. intel so intelligent ist und hier ein übelst verkrüppeltes Bios verbaut hat, und die Kiste, nachdem man das Netzteil einschaltet, erst einen "Selbsttest" durchführt. Der muss dann sein, der kann nicht beim ersten Booten sein. Nein, das wäre zu einfach und würde ja keine Daten vernichten. So geschah es mir! Mit dem Selbsttest wird auch die Festplatte kurz angefahren und wieder ausgeschaltet. Sehr gut! Während die Platte noch ihr DeJaVu hat, bekommt die den Kragen wieder zugedreht. Echte Profis sind hier am Werk gewesen.

Ich habe es kurz als Video festgehalten:



Workaround:
Schalter in die Zuleitung und wird eben nur noch so eingeschaltet.

Die haben schon mal besser gepfuscht!


So jedenfalls rockt das kleine Teil wirklich gut! ;)


Die blaue nervende Power-LED habe ich gegen eine "Rainbow LED" ersetzt
:D





Nachdem das originale interne "Netzteil" abgeraucht war, durch ein PicoPSU aus Amazon für 35eu ersetzt. ... Billiger wie das original Teil bestimmt.





Nun eine 40GB SSD eingebaut, Bilders:

Dsc_0018.jpg
Dsc_0019.jpg

Dsc_0022.jpg
Dsc_0024.jpg

Dsc_0026.jpg
Dsc_0027.jpg



Nun wäre noch zu überlegen, wie man die Optik mehr ver"Amiga"n kann...

Logo drucken, oder gravieren, oder ganz eine andere Front?

Das Board hat nur zwei Sata Anschlüsse, da dran hängt die SSD und das DVDrw Laufwerk.
Die Amiga Platte (hinten) hängt an USB, funktioniert eigentlich auch, aber richtig an einen IDE oder Sata Anschluß wäre noch mal feiner...
Bräuchte man entweder einen mPCI Kontroller oder extrem flachen PCI Kontroller...
PCI flach + IDE wäre besser, so kann ich die Platte jederzeit am echten Amiga anklemmen.


Hier noch ein Video vom Start:


(der Explorer startet noch mit...)



... stay tuned ...


  
 
 
 [ 1 Beitrag ] 



cron



Homepage Besucherzähler